Ratings Web Part: Display But No Action

Jun 5, 2008 at 6:11 PM
I've gotten the ratings web part to display on a page.  But when I hover over the stars, nothing happens.  Clicking them invokes nothing.

No errors just no action.
Coordinator
Jun 6, 2008 at 6:14 AM
You probably don't have ASP .NET AJAX properly configured for SharePoint. Check out this post: http://blogs.msdn.com/sharepoint/archive/2007/03/02/integrating-asp-net-ajax-with-sharepoint.aspx

Steps 1-7 under "Extending SharePoint web.config files with Microsoft ASP.NET AJAX 1.0" topic.

After completing steps in blog post above, you need to change assembly version numbers from 1.0.61025.0 to 3.5.0.0.

There is also solution here in CodePlex that does this automatically. However, I don't have experience of it.

mda1125 wrote:
I've gotten the ratings web part to display on a page.  But when I hover over the stars, nothing happens.  Clicking them invokes nothing.

No errors just no action.


Jul 10, 2008 at 11:18 AM
Hi guys !

I've got the ratings WP too. that's really a sexy one :p

the problem is that: i've installed and deployed it, update the web.config and install the ajaxifymoss.
then when i hover i can rate and comment, but when i click Send.... nothing appends, any ideas ??
Jul 10, 2008 at 11:21 AM


Mickey75019 wrote:
Hi guys !

I've got the ratings WP too. that's really a sexy one :p

the problem is that: i've installed and deployed it, update the web.config and install the ajaxifymoss.
then when i hover i can rate and comment, but when i click Send.... nothing appends, any ideas ??


Ok appears weird.... i've try to change the page, and come back on it, that's working !!
Jul 10, 2008 at 11:26 AM
Hi again guys,

does anyone know where the feebacks going ?!
Coordinator
Jul 10, 2008 at 1:13 PM
Edited Jul 10, 2008 at 1:13 PM
Hi!

Check the lists in the root of the site. Feedback posts are on same list with ratings.

-Mikko
Jul 10, 2008 at 3:35 PM
yup Mikko,

just gotcha, thx :)

now am trying the MSIT Ratings did you check it out ?

best regards,

<Mickey/>
Coordinator
Jul 10, 2008 at 8:32 PM
I haven't tested those. I visited the CodePlex site and it looks pretty promising. They seem to have external database for ratings, that of course allows much more complicated features.

Hey, would be great if you could post here your experience about MSIT Ratings.

-M
Jul 11, 2008 at 8:56 AM

hi Mikko,

guess i'll post my feeback on the discussion related to MSIT Rating :) check it ^^

 

best regards,

<Mickey/>

nb: the only point where i still block is around the line in javascript, i've tried it on an english collection site, but it's appear that's not working on a french one .... i've to try it :)
keep in touch.

Coordinator
Jul 12, 2008 at 12:14 PM
I am too lazy to follow competitors. :) Only if MSIT Ratings were superior, I could probably freeze development of Ratings web part. No need to do things twice if MS is already offering same features for free.

btw. there is also this project: http://www.codeplex.com/spdocrating. I haven't tested this either.




Jul 21, 2008 at 6:52 PM
Ok guys I have bben working on this webpart from a week now but its the most confussing documentation I ever got on codeplex sites.
I did install the web part and its working fine up to the point to create new ratings but when I try to use any of three webparts which come with solution package its start giving me trouble for example to use ContentRatingReview web part u need to enter content source id and item id but code plwx didnt mentioned in there documentation that what are these.
Even Contentratingresult webpart is giving some error, also one I click on Read Review nothing happens.

Any suggestion?

Thanks
Bharat
Coordinator
Jul 21, 2008 at 7:43 PM
Hello!

So have you been using the MSIT Rating or SPDocRating? Try asking help from discussions in those CodePlex-sites. I haven't tested those and probably won't have any extra time to do so in near future.

Good luck! :)
Jul 21, 2008 at 9:35 PM
i am using msit rating and i tried the codeplex group but no reply anyways whenever u get time and u come across anything please let us know
i will really appreciate that
Jul 22, 2008 at 6:43 PM
Edited Jul 22, 2008 at 6:48 PM


bchopra22 wrote:
i am using msit rating and i tried the codeplex group but no reply anyways whenever u get time and u come across anything please let us know
i will really appreciate that

If you get errors, you can try to delete all librairy created by MSIT Ratings. (there is 4 librairies)
- Content Rating

<!--ConfigurationData

<!--Content Rating Configuration Settings

<!--Content Rating Store Configuration Settings


Destroy all solution, and reinstall it :)
addsolution
deploysolution

Create the DataBase, by using CreateRatingsDB.sql already on da solution and RatingsDB.sql on the solution too :)

activate solution

Add the following line into your masterpage by SPD : 

<script language="javascript" type="text/javascript" src="/ContentRatingResourceFiles/Scripts/Ratings.js"></script><o:p></o:p>


On setting of the Content Rating Store Configuration Settings you must modify a line:
Data Source=<Server> ;will become Data Source=myserver ;  (without the "<" ">")

After that you're able to enable the ratings on librayries or lists or whereever you want :)

Regards,
<Mickey/>

Coordinator
Aug 6, 2008 at 10:23 PM
In general I am little disappointed of CodePlex community activity. People download binaries but do not give feedback. Oh well...
Aug 19, 2008 at 11:41 AM
Hi Guys,

did you succeed to rate an article on the Pages library ?
because i can't do this on this kind of library, BUT i can rate items on all other library... so to rate a page i've to download it, and uploed it to another library.... not friendly at all... any idea ?


regards,
<Mickey/>
Coordinator
Aug 20, 2008 at 11:11 AM
I have to check this out. I have to admit that I haven't tested this web part with publishing enabled web sites enough. I also opened work item about this...